Level 2 Contributor

Exchange 2013 Federation certificates Invalid

Dear Support,

We have  3 CAS server and 3 Mailbox servers, recently we observed that our Federation certificates is showing invalid so i tried to renew but it giving error "

A special Rpc error occurs on server MBX01: Federation certificates can only be managed through the FederationTrust tasks." and after automatically multiple federation certificate created.

so i tried to create certificate federation from powershell so after create certificate when i ran "Set-FederationTrust -Identity "Microsoft Federation Gateway" -Thumbprint 6A99CED2E4F2B5BE96C5D17D662D217EF58B8F73 -RefreshMetaData 

so i am getting error 

Cannot update certificate until the federation trust is provisioned with STS.
    + CategoryInfo          : InvalidArgument: (:) [Set-FederationTrust], CannotUpdateCer...sionedException
    + FullyQualifiedErrorId : [Server=MBX01 ,RequestId=356565-af56-44f8-8cee-24f8b30c8729,TimeStamp=7/28/2019 7:27:
   35 AM] [FailureCategory=Cmdlet-CannotUpdateCertificateWhenFederationNotProvisionedException] D49A39F8,Microsoft.Ex
    + PSComputerName        : cas1.xyz.com



Please advice, Your prompt reply will be highly appropriated 


Who Me Too'd this topic