Visitor 1

Server 2016 build 1607 clients not reporting to WSUS Servers

I have built two WSUS servers to test things in a new client environment, one is Server 2012 r2 and the other is Server 2016 - due to their licencing limits.


Both servers work great for all client machines, except Server 2016 servers. These servers do contact the WSUS fine, does not matter if they are set to 2012 r2 or 2016 WSUS server, they maintain regular contact. But never report to the WSUS server, no matter which one I have them pointing at.


The client 2016 servers are all build 1607.


I have tried a lot of things so far, main ones being as follows:


  1. Checked for duplicate WSUS client ID or other duplicate WSUS information in all affected machines registries - no issues.
  2. Run the wuauclt.exe commands - yes I know they are depricated but worth a try
  3. Run usoclient commands
  4. Used serveral scripts that have similar effects from the powershell gallery. Mostly ones that clear out the softwaredistribution folders, caroot/caroot2 folders, reset WSUS authorisations using either WUAUCLT and USOCLIENT commands, etc..
  5. Compared all installed updates against the one 2016 that does work and where possible removed or installed updates to get them the same versions of build 1607
  6. Updated machines from either intenral WSUS server and others direct from Microsoft updates manually from the catalogue and automatic.
  7. Build new machines to test base image build, still does not work.


One machine, which was used using the Hyper V image in VMM does work Its build



I cannot get the rest of the machines to this build number easily though.


I know I am not the only person having this issues, trawled so many posts online but none of the solutions came close to helping.


Any help would be greatly appreciated!





Community Manager

Hello Danny,


Thanks a lot for sharing this with the Community!

I`ve seen a similar thread on MPC :

Have you tried the following reccomendations ? (to your points 5&6)

First thing  would be to check if those clients have the correct configuration and are even trying to contact WSUS. See 


The technical support communities might also help since they focus on provising help on technical issues: 


Let us know if these helps,