Hero Banner

Feedback & Support Discussions

Reply
Visitor 1

S2d add sad cache after pool and drive creation

I have a S2d cluster of 4 nodes for learning and testing. Nothing production is on it but I would rather not loose any data.

I originally built it with 20 15k rpm drives and no cache but now I have about 40 vms running on it and it's unusabley slow. I grabbed some industrial ssds and added them (8 in total) but it just made my pool bigger. I checked and they are listed as ssd. I used power she'll to force the. To journeling but no chage. If I try to enable caching I get an error that there are no suitable drives.

I have read a million posts but nothing seems to be about adding cache just expanding.

I am worried if I keep messing with stuff I will break the virtual drive and loose all my data.

Just for reference. 4 nodes each with 5 147gb spinners and 2 200gb ssds all sas.
1 REPLY 1
Highlighted
Microsoft

Re: S2d add sad cache after pool and drive creation

This is not possible (not supported, not tested, not designed this way), the S2D Cluster has to be set up again, the system was not designed to change the provisioning state from "no cache" to "cache". So yes, you should be worried if you continue to mess with this.

 

Have checked internally with the S2D experts, and they confirmed it is a strict no.

 

btw - this forum is more intended to have discussion on support options for partners, experiences etc. - technical guidance on specific technical problems are most of the times better placed in the Tech Community since there are more tchnical experts monitoring this: https://techcommunity.microsoft.com/