Reply
Misosoppa
Level 2 Contributor

Partner Center slow

I wonder if it's just us in Japan, but I've always found the response time of the Microsoft Partner center sluggish. Is this a common problem you all face, or am I doing something wrong?

2 ACCEPTED SOLUTIONS
BrendanPrice
Level 2 Contributor

I know its been a while but you might want to know that I've found Firefox does handle Partner Center a lot better if you exclude the site from Firefox's "Advanced Tracking Protection" (click the shield icon next to the URL to bring up the menu for this). It's still slow, but at least now its on a par with Chrome.

View solution in original post

deela
Microsoft

@v-jillarmour  A support ticket has been filed with Partner Center to investigate the cause of the issue. I can advise when we have a response. cc: @JacquesvdHoven 

View solution in original post

24 REPLIES 24
JacquesvdHoven
Level 3 Contributor

Same problem here. Looking at the F12 Developer tools various requests take unbelievably long to receive a response. Some timeout and this has been the same for years. I've raised the issue before, but it's as if the Microsoft Partner team don't believe its an issue. 

v-jillarmour
Community Manager

@JacquesvdHoven We have a few more questions for you around this to try and help you. @deela can you help us here? 

deela
Microsoft

@v-jillarmour  A support ticket has been filed with Partner Center to investigate the cause of the issue. I can advise when we have a response. cc: @JacquesvdHoven 

v-jillarmour
Community Manager

@deela THANK YOU for your help! 

JacquesvdHoven
Level 3 Contributor

Okay, happy to hear if there are other solutions. 

v-jillarmour
Community Manager

@JacquesvdHoven I have someone to help you but they are OOF until Monday. Can you check back then for a new message from @deela ? Thanks so much and have a great weekend! 

JacquesvdHoven
Level 3 Contributor

@v-jillarmour I still haven't heard anything from @deela 

v-jillarmour
Community Manager

@JacquesvdHoven I just checked in with her and she hasn't heard anything back from the support team yet. 😞

v-jillarmour
Community Manager

@JacquesvdHoven I'm sorry to hear of your troubles here. Have you tried using a different browser? I'm not support and I don't have any technical help to offer you, but I will share your feedback! 

JacquesvdHoven
Level 3 Contributor

I have yes. Over the years I've used Firefox, then Chrome and now Edge. Incidentally, I can't see how just about every other Microsoft site responds within the norms but this one particular site has these performance issues. Something else is wrong and it's not be addressed. 

v-jillarmour
Community Manager

@JacquesvdHoven Thanks for letting me know, I will share this with the Partner Center Team! 

Red5Admin
Visitor 1

The site has been slow (especially on initial page load after login) for years. It would be nice if they would do something about it one day. I can be sure its not our end as we have replace everything except the building during the time its been slow.

Chris_AMPSYS
Level 2 Contributor

I don't know about everyone one else,

 

I have to refresh Partner Portal 3-4 times each time I need to work in it.
And even then I am not guaranteed it will load all items correctly. 

BrendanPrice
Level 2 Contributor

I know its been a while but you might want to know that I've found Firefox does handle Partner Center a lot better if you exclude the site from Firefox's "Advanced Tracking Protection" (click the shield icon next to the URL to bring up the menu for this). It's still slow, but at least now its on a par with Chrome.

Andra
Community Manager

Hi @HongZ ,

 

Please review this documentation to become a Global Admin.

https://docs.microsoft.com/en-us/partner-center/become-global-admin

 

thank you,

Andra

Andra
Community Manager

Hi @Misosoppa ,

 

I haven`t seen any other similar feedback.

Are you still seeing a slow response from PC?

 

thank you,

Andra

tnorman1st
Level 2 Contributor

We have found this to be true too. It takes 5+ secs to load any page or item in the partner center (since we started using it last year). Its that anoying that half my team dont use it anymore and sign in manualy to accounts in it 😞

 

the 5secs + sure does add up to a long time if you havent already got it open.

 

I have to keep a auto page refresher on the customer page to stop me having to reload it and spend ages getting back to the page lol

Andra
Community Manager

Hi @tnorman1st ,

 

I can imagine this slows down basic actions..

Interesting feedback and is the same issue in different browsers?

 

tnorman1st
Level 2 Contributor

Same speed in firefox and chrome. E.g. if i go to https://partner.microsoft.com then dashboard > csp > overview the first time it took 20secs to load the overview page. This was faster after the first load. We are on a leased line 100/100.

I do see an error report at the top? could this be related (attached) This happens every browser (all day today, i don’t remember seeing it before, but i use a auto refresher so i don’t have the issue everyone else does in my business!)

Andra
Community Manager

Hi @tnorman1st ,

 

Thank you for the detailed information. 

I have checked with the responsible team and no recent latency issues have been reported on the platform.

My recomendation is to contact support if you or your business continues to face this situation: https://partner.microsoft.com/en-US/supportAnnotation .png

 

 

 

 

Have a great day ahead!
Andra