Level 1 Contributor

Cannot complete Hardware Developer Program registration - page loops.

I have been trying to get support form Microsoft for the past 4 weeks now and I am still unable to get this issue resolved - hoping someone here can help. 


Prior to July 2021 in order to sign a Driver it was simply a matter of obtaining an EV Certificate. Now however Microsoft have stuck their finger in the pie and it is necessary to go via them. 

Fine if their website and process actually worked. 


The problem is as follows ; 

a) Log in to

b) Select the Home icon

c) scroll down and select Add Program

d) scroll down and under Hardware on the right side select Get Started. This is apparently the process you need to apply for to get a .sys type driver signed

e) Read the blah blah and click Next

f) *

This next page can either hang on Country or populate correctly. It's random. Refresh if it is hanging. 


Now you should see your partner details fully populated. 

Click Next

And the page just refreshes. Doesn't matter how many times I have tried. 


I have tried this from different browsers, different machines, even in Private mode (incognito etc)

The process is stuck here and I cannot get it to continue.

I'm desperate as we cannot proceed and this is holding up the release of the application. 


I am hoping someone can duplicate the process and let me know if you get to the next page or are stuck there as I am. 




Visitor 1


I am in the same situation.. @Akeo did you solved the problem?

Level 2 Contributor

No. I gave up.

Best, Sean
Community Manager

May I suggest you try posting this on the Tech Community to see if they have any suggestions on this? They have more technical members and hopefully they can help!! You will have to become a member of that community to post. 

Level 2 Contributor

I am in the same situation. Any update?


Level 2 Contributor

@Sean_C, I only got sorted out through a Microsoft support representative.


The thing is, I did post an update on this thread here at the time, with what they asked me to do and a reference to my issue number, so that people in your position could ask support to do the same for them, but it looks like the moderators removed my post (!)...

Basically, the content of my post was as follows:

1. I had to create a NEW outlook / live account to link that account to the original tenant, so that Microsoft could update that account PUID value. To access the PUID, you can sign into MSA account (outlook/live/hotmail) you created and go to
You’ll see an entry called Unique ID at the bottom of the page. Collect that number. This is the PUID that Microsoft needed.

2. Through the PUID, Microsoft then enrolled that new user to the existing Seller Account.

3. Once that was done, I was able to enroll for Hardware Registration.

So please contact Microsoft and reference support issue SRX1528538466ID ("Hardware | AKEO CONSULTING | Loop in registration process") and ask Microsoft support to perform the same steps for you.

Hopefully, Microsoft moderators will not delete this post again, because, clearly, people are still having registration issues and it is bewildering that they don't even want to let people who are stuck get a hint of how it can get resolved.

Level 2 Contributor


Thank you very much! I will follow your instructions.

Community Manager

@Sean_C I don't have any answers for you but @RachelP may be able to help us find a resource or updates. 🙂 Thank you! 

Level 2 Contributor

Well, through the creation of a test account, I found that you could "force" the next step by going to after you went through the "Registration - account details" page. There you will be able to download the signable file, sign it with your EV cert and upload your signed version to try to complete the process.


However, after I did all that, and validated that the final Review page had all the proper details, I still got an error after pressing the 'Finish' button ("Sorry, something went wrong. Please try again later.") and of course, I still didn't gain access to the Hardware panel in the Partner Center.


I'm starting to get the feeling that this whole matter is happening because we somehow didn't pay for the "privilege" of signing stuff with Microsoft, as found myself being asked to pay €14/€75 (for individual/company) when trying to register with a test account before I could proceed to the Account Details page. This request for payment is actually being asked on the region selection page, which is one of the page we seem to have an issue with. But somehow, I was able to proceed without payment, which is how I eventually found that the next page after the Account Details should be (well, there's a Certificate page in between, but it's just meaningless stuff about making sure you have an EV cert ready).


So now I'm completely screwed, because, since the system has seen my EV, I can't use it with a different account than the one I already used it (it'll ironically tell you that this EV has already been used for "registration"... yeah, right), and when I retry the process with my existing account, I only get the "Something went wrong" error, with no process completed.


Brilliant. I literally spent the last 7 months preparing my software and environment (and purchasing expensive stuff) to be able to sign software through the Hardware Developer Program, so that I could get something out in time for the release of Windows 11, but, unless Microsoft Support do a proper job (which really remains to be seen at this stage, especially as it's next to impossible to get in touch to a person who can actually do something about this issue) it'll all amount to nothing.

Level 1 Contributor

I feel your pain. As mentioned I am in the same position. Upsetting and frustrating. 

Level 1 Contributor

Well put Akeo,


For what it's worth I have been communicating with Microsoft Dev Center Support on this issue for the past "6 weeks". 


Just received another email from them this morning, asking me to provide my actual Hotmail/Live account details because apparently now they need that to be able to provide support. Apparently all the information one supplies when signing up isn't enough. I guess they could have asked for that MSA email address also at the time of registration, but that would require some actual thought on Microsoft's part. This now, six weeks into the support cycle. A Joke !


I have been transferred through 3 different departments so far with the obligatory waiting time in each. More over, with each I had to submit a "new" support request ticket with all the "same" info, same files, same images etc.  Apparently (as I was informed) their different support departments do not communicate with each other and do not share information. How's that for an IT company. Wonder how long we have to wait for now till the next step. 


We have tried the process from several machines here in Australia, and also in the US, same issue at both ends. 


Our EV certificate expires in October, (have been dead in the water since July 1), then we are up for another fee and another validation process. It is only since Microsoft stuck their finger in the pie as of July this year that all this fell apart. Prior to that one could sign a driver with an EV certificate and get on with life, Now it is a painful and traumatic experience with Microsoft involved - and their system that does not work !


Microsoft "If" you read  this forum - appalling support here for your developer / "partners"as you like to call them. Fix your systems so we can operate. !



Level 2 Contributor

For people having this issue, please try Chat Now (under Non-Technical Support - Dashboard) at to talk to a Microsoft support representative.


It appears that Microsoft is aware of the issue (at least, that's what the support person told me) and they should be able to help you through the registration process by e-mail.

Level 2 Contributor

Well, something definitely looks screwy up in the page's JavaScript (see attached picture) with an exception being produced when evaluating:



if (AccountDetails > HardwareRegistrationStep.AzureADAccount) { ... }



If I were to take a guess, I'd say that that AccountDetails variable, which probably resolves to an enum indicating the step of the process, is missing a HardwareRegistrationStep. prefix to evaluate properly, especially as what it's being compared to (HardwareRegistrationStep.AzureADAccount) does match another step.


So, at the very least there is a bug in the Hardware Developer Program registration web application, which may very well explain our issue, as it relates to variables that deal with changing the state of the process. But if this has been the case for at least 6 weeks, I really have to wonder how it flew under the radar for so long. Is nobody registering for the Hardware Developer Program? Or is it another case of yet another major corporation making it so incredibly difficult to report an issue to the application developers, that they live in blissful ignorance that have a major bug on their hand...


EDIT: Oh and I found one more report of another person having the same issue dating back to April 2021.

Level 2 Contributor

I have the same issue (page loops on, and I sure hope someone at Microsoft if monitoring this, because I went through the purchase of an expensive EV certificate and it will be all for nothing, and I will have completely let down users of my application, if Microsoft's web site makes it impossible to register for the Hardware Developer Program.


My problem is exactly the same as OP mentions: The "Registration - account details" page of the registration process loops into itself infinitely, without displaying any error or anything, and I just can't get through the next step of the process.


Is there anybody at Microsoft one can contact to go through the Hardware Developer Program registration? You can't just have developers literally spend months going through the (expensive and time consumming) motions of being able to sign drivers, only to make the whole process useless because your users simply cannot sign it to the program on account of a web application issue!


Microsoft, please realise that your Hardware Developer Program registration is clearly broken for some users, and do something about it!

Visitor 1

I have been able to get past the looping by using Firefox.  Edge and Chrome sometimes loop and sometimes the finish on the agreement page does not enable.  When you do click Finish it will just throw a web site error "Something went wrong" and that is where I am stuck.  I tried creating a second account but it would not let me finish because the EV certificate was the same as the other account.  I have 10 tickets in since 28-JUL-21 and no help.


Level 2 Contributor

Yes, that's the same stage I'm in right now. I have 4 tickets (2 with Hardware Submission & Signing / Account Management support and 2 with Partner support), and not much to report in terms of what I would qualify progress being made. And I can't try to work around the issue with my current account by creating a second account when the registration page offers it (which I get the feeling might work) because the system says that the EV has already been used for registration.


But I guess having yet more people publicly report that they are facing this issue is not entirely negative, because with each new person coming forward, we get closer to being in a position to start a Class Action Lawsuit against Microsoft, which might very well be the only language they'll understand. After all, even if mostly symbolic (and not encompassing the actual prejudice that's being done against users of our applications), we can put a verifiable and quantifiable price tag on the minimum financial amount this issue is costing us, which is the cost of an EV certificate/day * number of days we are being stuck due to Microsoft's portal not letting us use our EV cert.


If this goes for much longer without any sign of progress, and since, in the absolute, we do have legal ground to demand reparation from Microsoft, I hope that Microsoft can appreciate how they might leave us with no choice but to devolve what should be a purely technical matter into a legal one...